Symptoms

  • Provider uses APS-package Azure CSP version 7.7-33

  • Cancelation/disabling of Azure CSP subscription fails with a specific error in /usr/local/azure/site/log/azure.log on the application End-Point:

    2019-09-18 01:45:39,452 DEBUG [com.odin.azure.server.ServerLogs] (azure task-81) <SERVER> Incoming request: PUT https://192.168.231.87:10443/azure/aps/tenants/75bf9f55-e36d-49cc-a1d2-342d035131c5/disable
    ..
    2019-09-18 01:45:48,591 INFO  [com.odin.azure.model.Tenant] (azure task-81) The customer's tenant with the commerce ID '75bf9f55-e36d-49cc-a1d2-342d035131c5' is already deleted
    ..
    2019-09-18 01:50:41,024 DEBUG [com.odin.azure.server.ServerLogs] (azure task-81) <SERVER> Incoming request 'PUT https://192.168.231.87:10443/azure/aps/tenants/75bf9f55-e36d-49cc-a1d2-342d035131c5/disable' has been finished: HTTP 500 Internal Server Error
    - headers:
            API-Error-Category: service
            Content-Encoding: UTF-8
            Content-Type: application/json
    - body:
    {
      "error" : "com.parallels.pa.service.apsclient.exception.APSError",
      "message" : "Can't find resource with query 'aps/2/resources/?implementing(http://parallels.com/aps/types/pa/admin-user/1.2),limit(54000,1000)', type 'com.parallels.pa.service.acntmgmt.rest.PAAdminUser'",
      "category" : "service"
    }
    
  • Corresponding cancelation order typically gets stuck in status Long Running Operation. Failed event "Cancellation Order Placed" can be found in BA tasks list using ID of the subscription for search in field Parameters:

Key points of the scenario:

  • Azure tenant is already disabled in Microsoft
  • Azure APS-application starts to request all APS-resources of type http://parallels.com/aps/types/pa/admin-user/1.2 in the system
  • It leads to PAU-transaction aborting due to timeout

Cause

Software bug APSA-21493 Unable to disable particular Azure CSP subscription: Can't find resource with query

Resolution

The bug has been fixed in version 7.7-39 of Azure CSP application. Consider to upgrade your application in order to avoid similar issues.

Workaround for current version:

  1. Find relevant subscription here in PCP:

    PCP > Services > Azure Cloud Solution Provider > Click to the application instance > Customers

  2. Set option Do not suspend in Azure for the subscription:

  3. Resubmit subscription cancelation event:

    Billing > System > Settings > Events > Cancellation Order Placed > Event Log > Search by subscription ID in parameters > Resubmit

Notes: Workaround is suitable since service is already disabled in Microsoft

Internal content