Symptoms

Several Azure subscription was imported using bulk_tenant_import.py script.

Task "Provisioning "Tenant" for APS application Azure Cloud Solution Provider" fails with the following output:

APS Application Error:
400 Bad Request
[not_found] A message could not be sent to the recipient..

Body: {
"error": "not_found",
"message": "A message could not be sent to the recipient.",
"category": "api",
"context": "{\"name\":\"recipientEmail\",\"id\":\"user@contoso\"}",
"packageId": "eea5a717-k539-4a38-be11-a1b735dc8aa3",
"http_request": "POST /azure/aps/tenants"
}

In output of the task, email "user@contoso" mentioned while actually different email was specified in input file for script.

Cause

bulk_tenant_import.py script actually takes email specified in Administrative Contact Information on Billing side. This email is taken as a verification email for tenant. However, this email does not belong to any staff member of customer and task fails.

Resolution

It is not possible to changed verification email recepient. Such ability is considered to be implemented in scope of request #APSA-20458. In order to fix currently affected subscriptions, consider to contact CloudBlue Technical Support.

In order to avoid similar cases, make sure that email specified in Administrative Contact Information section met the following criteria:

  1. Email specified actually belongs to one of staff members of a customer.
  2. Email is accessible and customer could get verification email from this mailbox when necessary.

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