Symptoms
Any VE-related OACI operation (start, stop, migration, autoscale rules delivery) gets stuck and cannot complete. Subscriptions hang in Configuring state and VEs reside in transitional states.
Analyzing /var/log/pa/vps.log
on OACI IM, all threads marked as Shared executor thread are busy and not logging any new messages for a long time.
The last entry for the corresponding operation (for example, e9a5c33f-39c9-4c66-8f4a-a75b14bed0a0
) is:
2019-03-01 15:09:51,710 (e9a5c33f-39c9-4c66-8f4a-a75b14bed0a0) INFO CachingRouter [Shared executor thread #6 @1 @INTERACTIVE] - address:172.20.13.32
Cause
This behavior is recognized as CCU-19501 by CloudBlue R&D team.
Resolution
As an immediate resolution for the deadlock, the service should be restarted via upgrade-stop
call:
How to restart OACI Instance Manager services?
Please contact your TAM or PTA to check the status of the request.