Symptoms

When generating an RDE report for a reseller, one may notice lines that have RESELLER_* fields filled with some information while there is no data in CUSTOMER_* fields.

Cause

Two cases are possible here:

1) Lines with empty CUSTOMER_* fields are related to the Fake Reseller's (Operating Unit = Yes) transactions;

If a) report is generated on L1 level and b) L2 reseller is a fake reseller then CUSTOMER_* section of an RDE report will be empty for this fake reseller (because there will be no RDE transactions for such a reseller).


2) The reseller (Operating Unit = No) has more reseller's transactions regarding a particular customer's order than a number of details of that order. This may happen, for example, if a reseller's staff member cancells some customer's subscription and chooses to make a pro-rated refund to the customer while the Full Refund Period of the corresponding service plan period is not over. In such case, the reseller receives full refund from his vendor anyway while the customer receives just the pro-rated refund. This may be verified by checking a list of not invoiced purchases for the reseller and comparing them with the related customer's order:

  1. Check the reseller's transactions:

    • Using UX1:

      • Log in to UX1 under the reseller's account > Account > Account Status;
    • Using RCP:

      • Log in to RCP under the reseller's account > Billing > My Reseller Status
  2. Filter the reseller's transactions list by the customer's order number;
  3. Compare the number of the found reseller's transactions and details of the customer's order;

Resolution

This behaviour is expected and correct. The external system that works with RDE reports should properly treat report's lines with empty CUSTOMER_* fields.

There is a Feature Request #PFR-3728 "RDE to show information for Fake Resellers" to implement this functionality in Reporting Tool. Please, contact your Technical Account Manager/Service Delivery Manager regarding the current status of the Feature Request.

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