Symptoms
There is a Change Order to switch a Subscription Service Plan, which hanged in Provisioning
status.
Service Status of the respective Subscription is Changing Plan
.
The source Service Plan of the Subscription is based on PEMGATE
and the destination one is based on DOMAINGATE
.
Cause
The issue is caused by Service Plan upgrade misconfiguration. PEMGATE
and DOMAINGATE
Service Tempates are supposed to be used for different types of services, e.g. Web or DNS Hosting and Domain Registration. So the system is unable to perform switch between such Service Templates.
The ability to configure such upgrade is submitted as a software-related issue #FND-3128 "It is possible to configure upgrade plan from PEMGATE to DOMAINGATE one".
Resolution
Please remove such plan upgrade from the source Service Plan Upgrades tab and cancel such the Change Order as soon as it fails by timeout.
If order is stuck for too long, it can be failed by triggering event "Change Plan Completed" with the following parameters:
GateID=4;IssuedSuccessfully=0;Message=some_message;NewPeriod=xxx;NewPeriodType=xxx;NewPlanID=xxx;OrderItemID=xxx;OrigPeriod=xxx;OrigPeriodType=xxx;OrigPlanID=xxx;SubscrID=xxx
These parameters are the same as in the event "Change Service Plan" that was triggered when Change order was placed. You can find this event in BA CP - Operations - Tasks (search by Order Item ID, taken from the Order on the Provisioning Items tab).