Symptoms

readCSPAccounts.py script is unable to prepare import data with the following error:

TenantId 'd4545e15-4a04-4b0d-a6d5-14785252785e' , DefaultAdminLogin 'admin@contoso.onmicrosoft.com', Unable to prepare the import data because of error: The appropriate published service plan can not be found. CSP Id 'c2102fcd-a508-46eb-a705-a30e59e3c81c' [Office 365 Business Premium/Office 365 Business Premium] with billing cycle 'Annual'.

The following message is represented in sitelog (with DEBUG logging enabled) for target service plan:

[  16] DEBUG aps_endpoint: The billing period of the service plan '143631' and the billing period of its cloud subscription do not match. This configuration is not supported. A service plan must have the same billing period as its cloud subscriptions.

The target service plan is configured properly and has Yearly on Statement Day billing period.

Cause

Software-related issue #APSA-20738 "The service plan with the billing period type 'Yearly on Statement Day' should be taken into account by the import tool."

Resolution

Please contact your Technical Account Manager or Pooled Technical Associate (pta@cloudblue.com) in order to clarify current status of the issue.

As a workaround, disable option Align Billing Order with Statement Day for the target service plan.

Internal content