Symptoms

An attempt to place a Sales Order for a specific service plan hangs indefinitely, a subsequent attempt to place a new order results in the following error:

ERROR: canceling statement due to statement timeout
CONTEXT: while locking tuple (11,9) in relation "Account"

Also, the following could be observed:

  • One CPU core on BSS application node is constantly busy - top utility show increased CPU consumption compared to average;

  • Service plan configuration matches the following conditions:
    • contains Composite resource A with empty service Gate;
    • contains Composite resource B with included OA resource, has "Requires" dependency on composite resource A;

Cause

During the order placement, one thread stuck in infinite loop. The corresponding transaction still active and keeps locks on several tables in BSS DB which prevented further attempts to place orders.

This behavior has been recognized by CloudBlue R&D team as FND-2417.

Resolution

Please restart pba service to release locks and allow further order placement:

balnfe # service pba restart

Please contact your TAM or PTA to check the status of the request. In order to prevent such situations in the future, please either:

  • remove dependency on Composite resource A from Composite resource B;
  • replace composite resource B with regular OA resource (previously included in Composite resource B).

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