Symptoms
On attempt to view a custom logo for a payment system, one may see no image. When exploring this page through a browser developers tools, it can be seen that requests to /bss-www/nologin/srv/BLOBDOC/GetPicture fail to process.
Cause
Due to some reason, an internal user nobody
with ID -2
has an incorrect or empty password in the database. This user is created by the system and cannot be used to log into the control panel.
Resolution
To confirm that the nobody
user's password is incorrect, it is required to analyze the billing._amt_log
log file. Search for records matching a pattern "Updating.UID=-2.IntUsersBan.*FailedAttempts" to find moments when the nobody
user was locked by the system due to the incorrect password:
# grep Updating.*UID=-2.*IntUsersBan.*FailedAttempts /var/log/pa/billing._amt_.log
If any results found, contact the technical support with a request to find the root cause and apply the solution and fix the user's password.