Symptoms
Customer can see all service users on the platform while searching in CCPv1 by "Email (To Sign IN)", "Assigned Services", and "Enabled"=Yes search fields on Users tab at the same time .
Cause
This behaviour is caused by software-related issue #POA-113628.
Resolution
The issue has been resolved in OA version 7.3. Consider contacting your Technical Account Manager or Pooled Technical Associate Team (pta@odin.com) to arrange upgrade plan.