Symptoms

On attempt to pay for unpaid order and adding modal payment method in CCPv2 (UX1) there is no redirect to processing center. Instead, error appears:

"Login or Password is incorrect."

The same issue may appear in UX1 Marketplace, represented with:

  1. No ability to proceed to checkout after pressing Add to Cart button.
  2. POST request /aps/2/services/order-manager/orders/estimate?includeTaxes=false fails in Browser console with the same error.

Cause

This behavior is caused by software related issue #PBA-85522 (System property "com.odin.api.pbaApiSecret" is corrupted during upgrade of Payment management application). It appears after upgrade to OAP 7.4 version of product. During the upgrade one of system properties of Payment Management application gets corrupted.

Resolution

Contact the Technical Account Manager or Pooled Technical Associate Team at pta@odin.com in order to apply workaround for the issue.

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