Symptoms

A HTTP load balancer cannot be created for a Cloud Infrastructure subscription. The following error is displayed in Customer Control Panel:

HTTP load balancer could not be created. Please try another configuration or contact your hosting provider.

/var/log/pa/vps.log contains the error message at the same time:

2018-05-15 13:20:59,702 web_9be611dd-351c-4843-8aca-51e184729e2a_49 INFO JerseyClientLoggingFilter [pa-rest task-9] - 31 * [PACI<-IM] Client in-bound response
31 < 406
31 < Server: grizzly/2.3.22
31 < x-paci-request-id: web_9be611dd-351c-4843-8aca-51e184729e2a_49
31 < x-callback: false
31 < Content-Length: 42
31 < Date: Tue, 15 May 2018 10:20:59 GMT
31 < Content-Type: text/plain
31 <
P30002: Cannot find suitable hardware node

The subscription does not have allowed 'CT' technology with 'local' storage type in the definition of the corresponsing OS type resource (Free Linux, Windows Server or Commercial Linux).

Cause

Old Cloud Infrastructure hosting type requires container technology with local storage to be allowed on subscription to be able to create a Load Balancer.

The behavior is recognized as OACI issue with internal ID CCU-19586.

Resolution

The possible workaround that implies service template reconfiguration:

  • go to allowed storage types:

    • for old Cloud Infrastructure template they are defined in VE OS resource type ('Free Linux' or 'Windows Server')
    • for new CS Hosting template they are defined by the presence of CS Local Diskspace Usage resources
  • modify the template to include 'local' disk space type

Contact your Technical Account Manager or Pooled Technical Associate Team (pta@odin.com) to trace the status of CCU-17530 and discuss possible workaround as an alternative approach to fix issue on per-subscription basis.

Internal content

Link on internal Article