Symptoms

The MESSAGE handler is configured for the event Renewal Order Placed, notifications are sent correctly for the amost all renewal orders placed. However the customers whose subscriptions were restored from the status Terminated. by the button Restore Subscription click do not receive the notification. The task log does not have the event Renewal Order Placed for such renewal orders at all.

Cause

The issue is caused by the bug with id #PBA-84218 ("No event "Renewal Order Placed" on "Restore Subscription" button click").

Resolution

Send the renewal notice manually:

Home > Operations > Orders > renewal order

click button Send Notification and choose the required notification.

Internal content