Symptoms

After upgrade OA 6.x to OA 7.x attempts to switch to Billing fail.

Cause

The UI uses a privacy proxy to connect to the Billing node:

09:16:12.983 [default task-89] DEBUG c.p.p.c.e.b.billing_manager.BMHelper - Connection through proxy: 10.0.5.11:8008

Upgrade to OA 7.0 requires Management Node and Billing appliation server to be migrated to RHEL/Centos 7, which use newer SSL/TLS libraries and Billing settings do not support outdated SSL protocols by default:

[root@pbafe01 ~]# grep SSLProtocol /etc/httpd/conf.d/0ssl.conf
SSLProtocol all -SSLv2 -SSLv3 -TLSv1

On teh other hand, the proxy is running under Centos 5, which does not support newer TLS:

[root@linupps01 ~]# rpm -qa | grep openssl
openssl-0.9.8e-12.el5_4.6

[root@linupps01 ~]# rpm -qa | grep curl
curl-7.15.5-9.el5

[root@linupps01 ~]# cat /etc/issue
Red Hat Enterprise Linux Server release 5.6 Beta (Tikanga)

Resolution

Either disable proxy to connect to Billing at OA > System > Settings > System Properties > Use proxy for connection to Business Automation or install the privacy proxy node with the new OS and reregister it in OA.

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