Symptoms
In
Provider Control Panel > Cloud Infrastructure > Virtual Servers
Click any server and go to the history tab, initially it will load withno items found
'Monitor' tab does not load with the error:
Resource usage is not available for the server.
In
/var/log/pa/vps.log
on Instance Manager node the following events could be found:2018-02-20 05:42:59,437 (f3f0adee-2ec8-4e97-ab07-f3c9c293e1d4) DEBUG LazyListImpl [Grizzly-worker(4)] - Waiting for the next element, fetched so far: 0 2018-02-20 05:42:59,537 (f3f0adee-2ec8-4e97-ab07-f3c9c293e1d4) ERROR LazyListImpl [Grizzly-worker(4)] - LazyList max poll time exceeded 2018-02-20 05:42:59,538 (f3f0adee-2ec8-4e97-ab07-f3c9c293e1d4) DEBUG LazyListImpl [Grizzly-worker(4)] - No more elements 2018-02-20 05:42:59,538 (f3f0adee-2ec8-4e97-ab07-f3c9c293e1d4) DEBUG LazyListImpl [Grizzly-worker(4)] - No more elements in the iterator 2018-02-20 05:42:59,538 (f3f0adee-2ec8-4e97-ab07-f3c9c293e1d4) INFO CustomLoggingFilter [Grizzly-worker(4)] - 22841 * Server out-bound response 22841 < 200 22841 < Content-Type: application/xml 22841 < x-paci-request-id: f3f0adee-2ec8-4e97-ab07-f3c9c293e1d4 22841 < <?xml version="1.0" encoding="UTF-8" standalone="yes"?> <ve-history> <history-request-time-out/> </ve-history> 2018-02-20 05:42:59,669 () DEBUG ResultSetIterator [VF executor thread #196 @COMMON] - ResultSetIterator - ended
Cause
Software-related issue #CCU-17675 Empty VE History tab - LazyList max poll time exceeded
Resolution
For VE History, press Refresh
button on top-right corner, all history events will appear.
For the performance graphs on the 'Monitor' tab, there is no workaround, the fix is planned in one of the future updates.