Symptoms
After Azure CSP subscription provisioning, a welcome email is not sent out to the target client.
The following exceptions can be found in /var/log/pa/core.log
:
Sep 1 15:45:15.880 : INF [rest:1018 1:1863:7f8b106c6700 SAAS 1508266661]: [ HTTP] IN 127.0.0.1:47862 Begin request: "GET /aps/2/packages/748dd292-d684-412f-bbfa-4391fbed135b/i18n/es_CO.json"
...
Sep 1 15:45:15.883 : ERR [rest:1018 1:1863:7f8b106c6700 SAAS 1508266661]: [ APSC] can't open file /usr/local/pem/APS/packages/748dd292-d684-412f-bbfa-4391fbed135b/i18n/es_PE.json
Sep 1 15:45:15.883 : DBG [rest:1018 1:1863:7f8b106c6700 SAAS 1508266661]: [ APSC] Rolling back because of std::uncaught_exception()
Sep 1 15:45:15.883 : DBG [rest:1018 1:1863:7f8b106c6700 SAAS 1508266661]: [ APSC] Nested rollback: 1508266661[2]
where 748dd292-d684-412f-bbfa-4391fbed135b
is the UUID of the currently active Azure CSP APS package.
[root@osscore ~]# head /usr/local/pem/APS/packages/748dd292-d684-412f-bbfa-4391fbed135b/APP-META.xml
<application packaged="2017-08-10T07:54:18" version="2.0" xmlns="http://aps-standard.org/ns/2">
<id>http://www.odin.com/app/azure-csp</id>
<name>Azure Cloud Solution Provider</name>
<version>4.5.2</version>
<release>13</release>
<homepage>http://www.odin.com</homepage>
<vendor>
<name>Odin</name>
<homepage>http://www.odin.com/</homepage>
</vendor>
Cause
The issue is recognized as APS-43127, triggered by the absence of a custom locale.
Resolution
Create the custom localization add-ons for each popular language/country combinations in the system:
Contact your Technical Account Manager or Pooled Technical Associate Team (pta@odin.com) in order to trace the current status of #APS-43127.