Symptoms

Customer is trying to upgrade subscription using the CCP > Office 365 > Licenses (tab) > Upgrade (link), but facing the following error:

The operation has timed out

sitelog error:

DEBUG aps_endpoint: Get incompatible plans from /o365/check.php?acc=101234&cat=13829&subId=1010203
ERROR aps_endpoint: Error:
System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
   at System.Net.HttpWebRequest.GetResponse()
   at Office365.PBA.PBAProcessor.GetIncomptiblePlans(String checkerUrl, Int32 accountId, Int32 categoryId, Int32 subId) in c:\inetpub\wwwroot\O365App\App_Code\pba\PBAProcessor.cs:line 277

Cause

PBA API URL protocol is specified incorrectly in the check.php file of Office 365 Offer Compatibility Checker: https is used instead of http.

Resolution

Modify the /var/www/brands/cp.providerbrand.com/o365/check.php file, line 160:

- $file = file_get_contents("https://$PBAAPI:5224/RPC2",false, $context);
+ $file = file_get_contents("http://$PBAAPI:5224/RPC2",false, $context);

Restart is not required.

Internal content