Symptoms
Billing Period
of a reactivated subscription cannot be changed in Microsoft Cloud.
Example:
1. Customer purchased Business Essentials
subscription in OA with annual
Billing Period;
2. Customer destroyed this subscription;
3. Customer purchased Business Essentials
subscription but under another Service Plan - with monthly
Billing Period;
4. Office 365 Endpoint reactivated previous subscription in Microsoft Cloud, but its Billing Period
is annual
anyway.
Cause
Microsoft Cloud does not support Billing Period
attribute modification for subscriptions.
Resolution
Request #APSA-19457: "Office365: "BillingPeriod" property is not taking into account upon subscription reactivation" has been addressed to Odin Development team in order to handle this case on the OA side.