Symptoms

There has been a long running OA tasks, which kept "rescheduled" status. The corresponding order is in LRO (Long Running Operation) status on BA side. In more than a week the task on OA side got completed successfully, but order is left in LRO.

Cause

The issue is caused by long running (more than 7 days) task on OA side, PemRequest on BA side fails by timeout. The issue that order stucks in LRO is treated as a product bug, its id is #OA-5935 ("An order did not fail on timeout failure of the PemRequest").

Resolution

Please contact TAM/PTA team to get the order completed.

#OA-5935 has been fixed in OAP 7.4 version of product. Since OAP 7.4 it is possible to set up required timeout in file /usr/local/bm/etc/ssm.conf.d/global.conf. To do it the following steps should be applied:

  1. Go to Billing Application Server
  2. Open file /usr/local/bm/etc/ssm.conf.d/global.conf
  3. Add the following parameter to the [environment] part of the file

     PEM_IN_PROGRESS_TIMEOUT = <required timeout in seconds>
    

By default this value is set to 604800 = 7 days.

In case if the order has already got status "Long Running Operation" please contact TAM/PTA team to fix the order.

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