Symptoms

Office 365 subdomain form does not detect customer's subdomain, while customer has one or more Office 365 subscriptions provisioned.

Checking browser console it could be seen the following request:

https://127.0.0.1:6308/aps/2/resources/f3733c7b-...-7921440e38a4/checkAccount?accountId=1000061

returns:

{
  "has_o365": false,
  "is_multitenant": null,
  "tenants": null
}

what is not correct. has_o365 parameter value should be true in case at least one active Office 365 subscription.

Cause

APS resource of type Office365/Tenant is not consistent due to missed 16.6.x - 16.8.x package upgrade step (upgradeResourceSettings16-6To16-8.py script).

The issue is: initial_subdomain Tenant property is empty, while it should contain actual customer's subdomain value.

Resolution

Contact Odin Technical Support to fix the issue.

Internal content

Link on internal Article