Symptoms

Domain availability check in the Online Store takes a of time or fails with the following error:

No Domains found

Cause

The issue occurs in case if a lot of domain Service Plans are added into a Sales Catagory attached to a domain registration screen of Online Store so it takes a significant time to check availability of the given domain name for many TLDs.

Resolution

To reduce the amount of TLDs checked in the scope of one request, the following can be done:

  1. Uncheck the Popular TLD option of those domain registration Service Templates which are not required to be checked for availability. The system perfomes an such check on every domain Service Plan which has Popular TLD setting enabled in a Service Template as per the Provider's Guide.
  2. Set the DISPLAY_CREATE_SIMPLE parameter at Home > Products > Online Store > Screens > DOMAINSEXTENSION_SCREEN to False to prevent online store from performing the availability check for all domain Service Plans and displaying them as also available.

If the above is done but domain availability check still takes a lot of time, the issue is caused by #PBA-83493 "Domain availability check in the Online Store may take a lot of time due to long PlansListFeesWithTaxesGet_API execution".

For Odin Automation Premium Billing 7.4 if amount of Service Plans is not too big, but there is a Promotion by One-time Promocode with a lot of Promotional Codes gererated, the issue is caused by #FND-152 "bPromotion::fillPromotionCache performance affects domain availability check in the Online Store"

Contact your Technical Account Manager or the Pooled Technical Associate Team at pta@odin.com to clarify the status of the request in question.

If domain availability check fails with No Domains found error, a domain availability check request timeout can be inceased:

  1. On Online Store Host open the file /etc/httpd/conf.d/0ssl.conf and locate line

    ProxyPass /aps https://192.168.0.1:443/aps
    
  2. Add timeout=300 to the end of this line where 300 is the number of seconds:

    ProxyPass /aps https://192.168.0.1:443/aps timeout=300
    
  3. Add the same timeout on Blling Application host into file /etc/httpd/conf.d/ssl.conf.inc
  4. Reload httpd on both Billing Application and Online Store host:

    # service httpd reload
    

Internal content