Symptoms

A new reseller has been created. When adding a new brand for the reseller there is no option "Enable store", "Online store" part is not visible at all.

Cause

The store availability is checked by the API call to BA - StorePackageListForAccountGet_API. When this part of brand is absent, that means that no stores was returned by the API call. Most probably the reason is that the reseller is in the status "Not Initialized" on BA side, noone has ever reached the step 6 ("Online store setup") of the reseller's wizard.

Resolution

Finish the wizard, two things will be done - brand automatically created + option "Online store" will become available for the automatically created and all the further reseller's brands.

Internal content