Symptoms

CLM subscription is in Terminated/Removed status on Billing side, however, still exists in OA.

It cannot be removed from OA by API call with the output like:

[root@linmn01 ~]# curl -d@/tmp/pem.removeSubscription http://localhost:8440
<?xml version="1.0" encoding="UTF-8"?><methodResponse><fault><value><struct><member><name>faultCode</name><value><int>-1</int></value></member><member><name>faultString</name><value><string>org.omg.CORBA.UNKNOWN: </string></value></member></struct></value></fault></methodResponse>[root@linmn01 ~]

The following error message in /var/log/pa/core.log from the Management Node can be seen:

Dec  7 19:18:13.964 : DBG [openapi:13700 1:15323:7fb31a7fc700 CLM ]: [ CLM::CLM_impl::unprovideDisks] ===> ENTRY
Dec  7 19:18:13.966 : DBG [openapi:13700 p:-default-threadpool;-w:-Idle:859 pau]: c.p.p.tracer entry: com.parallels.pa.service.resources.ejb.ResourceManagementBean.getResource(22875)
Dec  7 19:18:13.966 : DBG [openapi:13700 p:-default-threadpool;-w:-Idle:859 pau]: c.p.p.tracer entry: com.parallels.pa.service.resources.ejb.ResourceManagementBean.getSubscriptionResource(22875)
Dec  7 19:18:13.967 : DBG [openapi:13700 p:-default-threadpool;-w:-Idle:859 pau]: c.p.p.tracer exit: com.parallels.pa.service.resources.ejb.ResourceManagementBean.getSubscriptionResource returning null
Dec  7 19:18:13.967 : DBG [openapi:13700 p:-default-threadpool;-w:-Idle:859 pau]: c.p.p.tracer exit by exception: com.parallels.pa.service.resources.ejb.ResourceManagementBean.getResourcejavax.ejb.EJBException: Plesk.ErrorHandling.ResourceManagement.NoSuchResource: IDL:Plesk/ExSystem:1.0
        at com.parallels.pa.service.resources.ejb.ResourceManagementBean.getResource(ResourceManagementBean.java:84)

There are no active CLM objects (VEs or disks) shown in CCP, but there's usage on CLM resources.

Cause

There is a disturbance in CLM unprovisioning workflow, which results in attempt to remove already non-existent objects, leading to failure. Issue is acknowledged as POA-114089.

Resolution

Contact your Technical Account Manager or Pooled Technical Associates Team in order to trace the current status of POA-114089

Contact Odin Technical Support for a workaround.

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