Search Engine: Elastic

Article ID: 131908, created on Dec 13, 2017, last review on May 5, 2018

  • Applies to:
  • Operations Automation 7.2
  • Operations Automation 7.3

Symptoms

Possible scenarios:

  1. APS-screen in CCP is loading forever. Browser console log contains the error:

    {
    "error": "APS::Util::Exception",
    "message": "Error: null value fetch."
    }
    
  2. Order in BA fails with error:

    APSC: Internal Server Error: Provision Function exception 'Rest\ResrException' with message 'Error: null value fetch.' in /usr/share/aps/php/aps/2/apsc.php:383
    

Cause

It can be a result of bug APS-42619 - database contains duplicate entries in aps_relation_info table.

Resolution

Contact your Technical Account Manager or PTA team (pta@odin.com) to trace the status of APS-42619 and discuss possible workaround.

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