Symptoms
An order or task for Office 365 service fails with the following output:
The last error - "Service Creation Failed: Parallels Operations Automation error #error_code #0, extype_id #1, module_id #Common, Internal error: APSC: Invalid partnerId: 1234.</code></pre>
Information from Office 365 sitelog
:
ERROR flow : Caught unknown error:
Code: '3000'
Message: 'Invalid partnerId: 1234'
Partner Exception:
property_name: advisor_partner_id
Base Description: Microsoft.Store.PartnerCenter.Exceptions.PartnerException: Invalid partnerId: 1234
Cause
There are two possible reasons:
- If mentioned identifier is zero -
Invalid partnerId: 0
- this behavior is addressed to Odin Development team as Request #APSA-18944: "Office 365 task fails with: "Invalid partnerId: 0". - If mentioned identifier is not zero -
Invalid partnerId: 1234
- invalid MPN_ID attribute is specified for Reseller on the Billing side.
Resolution
A software-related issue #APSA-18944 was fixed since Office 365 version 17.2
. Contact your Technical Account Manager or Pooled Technical Associates to schedule application upgrade.
In case invalid MPN_ID is specified - please contact Microsoft support in order to obtain correct PartnerId value and specify it as Billing Attribute in Billing > Reseller > Additional Information tab > Click "Edit"
and fill MPN_ID parameter.