Symptoms
After a subscription is transferred to another account, customers can no longer view information about domains in CCPv2. They encounter an error similar to the following:
Returned status 404. Message: undefined
HTTP request "http://example.com:8080/aps/2/resources/<resource UID>/features" returns 404 (Not Found).
The following exception can be found in /var/log/pa/core.log
:
Feb 19 15:01:05.831 : DBG [aps-service:295055 aps-service-task-196:1358 pau]: c.p.p.tracer exit by exception: com.parallels.pa.service.connectivity.ejb.CustomOperationProcessorBean.prepareEndpointRequest com.parallels.pa.service.aps.api.APSException: The operation on the resource '139913ed-8c52-4b75-b974-b286d75f2b87' is not allowed.
at com.parallels.pa.service.connectivity.ejb.CustomOperationProcessorBean.prepareEndpointRequest(CustomOperationProcessorBean.java:232)
at sun.reflect.GeneratedMethodAccessor535.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
Cause
This is a known software issue, POA-113408: zoneinfo APS resource is not linked to new account in domain subscription transfer.
Resolution
Download and run the POA-113408-fix-domain-reginfo-owner.py script:
# python POA-113408-fix-domain-reginfo-owner.py
The script can be run again, in case of new domain transfers.
The issue is resolved since Odin Automation 7.4.
See also the KB: https://kb.cloudblue.com/en/132352 "Problems with managing domains and APS resources after subscription transfer".