Symptoms

An attempt to synchronize Office 365 users or assign a license to a user fails:

Unable to refer the resource [UID] out of limits

Cause

There are several possible reasons:

  1. Office 365 service template contains duplicated License or Addon resource types (resource types which are linked to the same License or Addon APS resource. Information about the link could be obtained on Activation parameters tab of corresponding resource type).

  2. Software-related issue #APS-38904. Some Office 365 User resources were created improperly.

Resolution

Case 1:

Detect and remove duplicated resources from a service template and corresponding service plans. The following script could be used in order to detect duplicated resources:

getO365DuplicateResources.py

Example of usage:

python getO365DuplicateResources.py --st=6

--st - ID of corresponding service template.

Additionally, synchronization process was drastically reworked in Office 365 19.2 in scope of request #APSA-20007. Since this version, licenses are no longer consume usage from of corresponding resource types in Odin Automation. Due to this change, the issue should no longer appear on this version and above. Nonetheless, it is recommended to remove duplicated resources from the platform.

Case 2: Software issue #APS-38904 is fixed starting from Odin Automation version 7.1. Please consider upgrading to the latest version of the platform.

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