Symptoms

After pressing Add new IPv4 address button in CCP for a VPS subscription, the generated order fails.

There is a change_environment_network task in the Task Manager with the output of:

APS Application Error:
500 Internal Server Error
[ApplicationUnknownError] [APS] {
"source": "APS",
"message": "[APS] {\n\t\"error\": \"Plesk.ErrorHandling.dns.DuplicateDNSRecord\",\n\t\"message\": \"Can not create DNS Record for '__host__'.\\t\\tThere is an existing __rr_type__ record (__host__ __data__, #__rr_id__) already.\",

As a result of the task run, an extra IP was added to the VE and became visible at Services > Cloud Infrastructure > Servers > your server page, but not displayed in CCP.

Prohibit duplicate DNS records system property is enabled at System > Settings > System Properties.

Cause

The behavior is acknowledged as a software issue CCU-17319: Overusage of IPs if 'Prohibit duplicate dns records' is enabled..

Resolution

The permanent solution is planned to be included into one of the product updates.

The workaround:

  1. Remove the IPs with drop-ip OACI API request, example:

    [root@osscore ~]# cat reconfigure.xml
    <?xml version="1.0" encoding="UTF-8"?>
    <reconfigure-ve>
      <reconfigure-ipv4>
        <drop-ip ip="203.0.113.2"/>
      </reconfigure-ipv4>
    </reconfigure-ve>
    
    [root@osscore ~]# curl -u'admin:***' -X PUT -d@reconfigure.xml http://192.0.2.2:4465/paci/v1.0/of/1008409/ve/server-1015353-1 -H "Content-Type: application/xml"
    
  2. Disable Prohibit duplicate DNS records system property.
  3. Run the failed task, complete the failed order.
  4. Enable Prohibit duplicate DNS records system property back.

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