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Article ID: 131687, created on Oct 27, 2017, last review on Jul 14, 2018

  • Applies to:
  • Operations Automation 7.2
  • Operations Automation 6.0
  • Business Automation 6.0

Symptoms

Customer upgraded an exchange subscription to a new plan, but Exchange mailboxes were not moved.

Cause

Customer subscription was not upgraded, but a new subscription was created. Mailboxes originally belong to subscription which was put on hold and thus disabled. After a hold period it was removed and possibly terminated. Mailboxes are still present on Exchange side, but inaccessible due to stopped subscription. This subscription may not be activated from Control Panel anymore.

Resolution

Use this article for Exchange 2007. For newer Exchange versions use article 132228

You will require access to CCP, Management node and Exchange server. Email address and login credentials will stay the same, existing messages will be moved to a folder in newly created mailboxes. Other parameters will not be migrated. Please follow the procedure below:

  1. If the source subscription is removed it should be enabled again, if it is terminated it could be enabled only through API request to MN such as:

    # curl -k -d@/tmp/pem.enableSubscription.xml https://localhost:8440
    

    .

    <?xml version="1.0"?>
        <methodCall>
           <methodName>pem.enableSubscription</methodName>
              <params>
                <param>
                  <value>
                    <struct>
                      <member>
                        <name>subscription_id</name>
                        <value><int>1060307</int></value>
                      </member>        
                    </struct>
                  </value>
                </param>
              </params>
            </methodCall>
    
  2. Delete the mailboxes from OA using Customer Control Panel > Exchange. These mailboxes will become Disconnected on Exchange Server, but will stay there for a month with all the data.

  3. Find mailboxes in Exchange Management Console > Recipient Configuration > Disconnected Mailbox. You will probably need to connect to one of the servers, keep switching the servers till you find desired mailboxes. Please note it may require a certain amount of time for mailbox to appear in "Disconnected Mailbox" section, be patient.

  4. Create dummy users on exchange side for example in hosting.local to connect those disconnected mailboxes to. Use "Active Directory Users and Computers" tool.

  5. Connect those mailboxes to corresponding dummy accounts, using Exchange Management Console (EMC) or Exchange Management Shell using the following command:

    Connect-Mailbox -Database <MailboxDatabase> -Identity <MailboxIdParameter>
    

    Database should look like Server\Storage_Group\Mailbox_Database

    e.g. CAS01.hosting.local\SG03\SG03DB

    Identity should be an email or GUID

  6. Create mailboxes via Control Panel using "add new mailbox" or "import mailboxes" buttons, select "Existing Service User" - this way login and password will stay the same. Please note "import mailboxes" does not import existing mailboxes, it imports a CSV file to create multiple mailboxes at once.

  7. Check newly provisioned mailboxes on exchange node in EMC > Recipient Configuration > Mailbox and Run Exchange Management Shell and execute the following commands:

    Find out GUID using the following command in EMS:

    get-mailbox <MailAddress> | Format-List
    

    You will need to grant full access for a user you are logged in with (usually pem_admin) to both source and target mailboxes:

    Add-MailboxPermission <MailAddress> -User "hosting\pem_admin" -InheritanceType All -AccessRights FullAccess
    

    Export the data to a folder of corresponding new mailbox.

    export-Mailbox -Identity <MailboxIdParameter> -TargetMailbox <MailboxIdParameter> -TargetFolder <String>
    

    Use email or GUID of the mailboxes for MailboxIdParameter.

  8. Please disable the old subscription if it was enabled in the first step.

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