Symptoms
Customer has an Office 365 subscription in Terminated \ Not Provisioned
status.
Corresponding "Unprovisioning "Subscription" for APS application Office 365"
task fails:
"code": 500,
"message": "Unable to deactivate Cloud subscription. The operation must be repeated.",
Cause
Affected subscription was not provisioned on Microsoft cloud.
This behavior is reported to Development team as request #APSA-18360: "Unprovisioning task fails: Unable to deactivate Cloud subscription".
Resolution
The issue was permanently fixed in the Office 365 17.2 APS application.
Please contact a member of Pooled Technical Associates(pta@cloudblue.com) or your Technical Account Manager to schedule Office 365 upgrade to the latest version or discuss the possible workaround.