Symptoms

Order for Office 365 subscription has been successfully completed. There are no failed tasks in OA related to newly purchased subscription.

However, licenses are not provisioned in MOP and OA.

On attempt to change limit for the license in OA, following can be seen in sitelog:

    0000-10-08 00:09:52,978 [  28] ERROR flow        : Create the subscription failed.
    Partner Exception:
    Error Category: Forbidden
    Service Error Payload: 
    Error code: 2085
    Error message: Offer <UUID> is not eligible for purchase

Cause

The error is returned by the Microsoft Partnet Center API. It means this offer either is not available for sale to the provider, or the offer is EOL.

Resolution

Make sure that the offer in question is available for sale:

  1. Go to https://partnercenter.microsoft.com
  2. Go to Dashboard > Pricing and offers > Offers from Microsoft > Current and download the actual Cloud Reseller Pricelist

  3. View the pricelist and make sure the offer is present in the list.

In case the offer is present in the pricelist, please contact Microsoft Technical Support. In other case, it is required to cancel the subscription and check that all Unprovisioning tasks related with teh subscription are successfully completed.

Internal content

Link on internal Article