Symptoms

The task Register domains ('example.com') in Autodiscover for service #5 failed with the error:

Provisioning request failed. Call of method "SW Managed Exchange::UnregisterDomainsFromAutodiscoverRedirect" failed.
Type: Parallels.Wpe.Utils.WpeProcedureException.

Inner exception(s):
-------------------
Exception calling "Execute" with "3" argument(s): "The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)"

Cause

A corresponding Exchange server is unavailable for incoming WMI requests.

Resolution

Go to the WPE node and find the error in the C:\Program Files\Parallels\Windows Provisioning Engine\Logs\wpe.log file:

DEBUG   2017-10-22 02:46:22 (824/3196): EXECUTING procedure action "File System Provider Ex::applyXSLT", input <executeData> is:

<executeData>
  <host>EXCAS01</host>
  <fileName>AutodiscoverRedirect.config</fileName>
  <xslt>&lt;?xml version="1.0" encoding="UTF-8"?&gt;
&lt;xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0"&gt;
    &lt;xsl:output method="xml" indent="yes" encoding="UTF-8" version="1.0"/&gt;
    &lt;xsl:strip-space elements="*"/&gt;

    &lt;xsl:template match="@*|node()"&gt;
        &lt;xsl:copy&gt;
            &lt;xsl:apply-templates select="@*|node()" /&gt;
        &lt;/xsl:copy&gt;
    &lt;/xsl:template&gt;

    &lt;xsl:template match="Domain[.='example.com']"&gt;
    &lt;/xsl:template&gt;

&lt;/xsl:stylesheet&gt;</xslt>
  <sourcePath>C:\Program Files (x86)\SWsoft\PEM\WebSites\AutodiscoverRedirect\Autodiscover</sourcePath>
</executeData>
DEBUG   2017-10-22 02:46:22 (824/3196): Call method "File System Provider Ex::applyXSLT"
INFO    2017-10-22 02:46:22 (824/3196): Procedure "File System Provider Ex::applyXSLT" - (ENTER)
DEBUG   2017-10-22 02:46:22 (824/3196): Create COM instance for 04711809-f996-47f1-b96a-88e253e73be2: base pointer 269588016, index 0, element size 16
ERROR   2017-10-22 02:46:43 (824/3196): The RPC server is unavailable. (Exception from HRESULT: 0x800706BA), Details: System.Runtime.InteropServices.COMException (0x800706BA): The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)

In the <executeData> section find the host name (EXCAS01 in this example) - this is the affected Exchange host.

Check the following possible reasons of the broken WMI communication:

Firewall

Go to the Excahnge node and make sure it is not blocking incoming connections from the WPE server. Please refer to the Firewall Configuration Guide for details.

Network hardware

In case the WPE and Exchange servers are in different subnets, make sure the aforementioned ports are not blocked by the router.

OS services

Check if the following services are running on the Exchange node:

  • Remote Procedure Call (RPC)
  • Remote Registry

If all checks does not help try to reboot the Exchange server, as it can be an OS/AD domain issue, which can be automatically resolved after system restart.

How to troubleshoot

Go to the WPE server and run in the PowerShell console:

Get-WmiObject win32_SystemEnclosure -Computer EXCAS01

In case of WMI unavailability, the following error will be displayed

Get-WmiObject : The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)

When WMI is available, the output like below should be given:

Manufacturer   : No Enclosure
Model          :
LockPresent    : False
SerialNumber   : None
SMBIOSAssetTag : No Asset Tag
SecurityStatus : 3

Internal content