Symptoms

A sales order and the task Provisioning "Tenant" for APS application Office 365 fail with the error:

500 Internal Server Error
[ApplicationUnknownError] Value cannot be null.
Parameter name: key.
Body: {
"code": 500,
"message": "Value cannot be null.\r\nParameter name: key",
"additionalNonlocalizableMessage": "",
"error": "ApplicationUnknownError",
"http_request": "POST /Office365GatewayApplication01/aps/tenants"
}

The following records are registered in sitelog:

2017-10-08 12:09:08,287 [  52] ERROR aps_endpoint: TenantsController.Post finished by exception System.ArgumentNullException: Value cannot be null.
Parameter name: key
2017-10-08 12:09:08,287 [  52] ERROR aps_endpoint: System.ArgumentNullException: Value cannot be null.
Parameter name: key
StackTrace:    at System.Collections.Concurrent.ConcurrentDictionary`2.GetOrAdd(TKey key, Func`2 valueFactory)
   at Parallels.APSCommon.WebApi.ApsTypesHelper.GetApsTypeWithoutVersion(String apsType)
   at Office365.APS.SubscriptionsController.GetOfferLimits(ApsApiContext apsContext, String tenantApsId, Office365App globalSettings, IRequestContext requestContext, List`1& offers, List`1& addons, Tenant& tenant) in c:\inetpub\wwwroot\Office365GatewayApplication01\App_Code\aps\SubscriptionsController.cs:line 1021

Cause

Two or more resource types referring to the same license APS resource are included into the same service template. Such configuration is incorrect and not supported.

Resolution

  1. Check the service template for the resources with similar names.
  2. Check if such resources have the same Resource UID in their activation parameters.
  3. Make sure the duplicate resource have zero usage and delete this resource first from service plans, then from the service template.
  4. Resubmit the task.

In case Odin Technical Support is required, please submit a support request.

Internal content

Link on internal Article