Symptoms

On an attempt to open VE VNC console in Provider's or Customer's CP, the following error appears:

Failed to connect to server (code: 1006)

Direct connection to the VE console on the corresponding Virtuozzo node with any VNC client works correctly.

/var/log/httpd/oaci_error.log on the Virtuozzo node does not show any errors.

When tracing the network communication between the UI node and the Virtuozo node (port 80), an RST packet can be found on the UI node:

...
01:08:24.195146 IP 172.18.86.11.80 > 172.30.231.59.50521: Flags [.], ack 907, win 243, length 0
01:08:24.226202 IP 172.18.86.11.80 > 172.30.231.59.50521: Flags [P.], seq 1:162, ack 907, win 243, length 161
01:08:24.226224 IP 172.30.231.59.50521 > 172.18.86.11.80: Flags [.], ack 162, win 123, length 0
01:08:24.226501 IP 172.18.86.11.80 > 172.30.231.59.50521: Flags [R.], seq 162, ack 907, win 123, length 0

While the Virtuozzo node does not send the packet and keeps probing:

02:38:53.502581 IP 172.18.86.11.80 > 172.30.231.59.50521: Flags [P.], seq 1:162, ack 907, win 243, length 161
02:38:53.502599 IP 172.18.86.11.80 > 172.30.231.59.50521: Flags [P.], seq 162:176, ack 907, win 243, length 14
02:38:53.654148 IP 172.18.86.11.80 > 172.30.231.59.50521: Flags [P.], seq 162:176, ack 907, win 243, length 14
02:38:53.931151 IP 172.18.86.11.80 > 172.30.231.59.50521: Flags [P.], seq 1:176, ack 907, win 243, length 175
02:38:54.485161 IP 172.18.86.11.80 > 172.30.231.59.50521: Flags [P.], seq 1:176, ack 907, win 243, length 175

Cause

An interim firewall equipment between the UI node and the Virtuozzo node(s) blocks the communication on port 80 via websockets protocols.

Resolution

Contact the network administrators to address the issue.

Internal content