Symptoms

Order to change service plan fails without any clear reason, error message is shown:

Service Plan change for Subscription #name failed. 

Cause

The source or destination service plan is based on PEMGATE but has some DUMMYGATE resources included. An order to switch to such service plan fails due to the bug #PBA-82341 ("It is impossible to switch subscription plan to PEMGATE plan which has a dummygate resources").

Resolution

This issue is fixed since OAP 7.3. Contact your Technical Account Manager or Pooled Technical Associate Team at pta@odin.com to develop a plan for upgrade.

Workaround

As a workaround, it is possible to trigger an event of type "Change Plan Completed" which will complete the provisioning item:

  1. Open the failed order at the "Provisioning Items" tab;
  2. Write down the failed provisioning item's ID (enable the corresponding checkbox in the "Select Columns" drop-down menu if item's ID is not displayed);
  3. Go to the System > Settings > Events > Event Type 'Change Plan Completed' > Event Log, enter the failed provisioning item's ID to the "Parameters" field and press the "Search" button;
  4. Find the most recent event with the parameters like the below and copy its value:

    GateID=X;IssuedSuccessfully=0;Message=Service Plan was changed for Subscription #XXXXXXX.;NewPeriod=X;NewPeriodType=X;NewPlanID=XXX;OrderItemID=ZZZZZ;OrigPeriod=X;OrigPeriodType=X;OrigPlanID=XXX;SubscrID=XXXXXXX
    
  5. Switch to the "General" tab and click the "Trigger Event" button. Paste the parameters from the step 4 replacing the IssuedSuccessfully=0 to IssuedSuccessfully=1 and press the "Send" button.
  6. Open the required order and check if the provisioning item has the "Completed" status. If yes - then resubmit the order for provisioning. In case if it contains no more provisioning items to be processed, the system will complete the order successfully.

Internal content