Symptoms

  1. Attempt to destroy subscription fails with:

    Destroying service of Subscription #1203315 failed: Parallels Operations Automation error #extype_id #37, module_id #SaaS, APS resource for '/aps/2/application/subscriptions/88a567f2-aa39-4dd1-a816-606f3a0189e3' with id '1203315' was NOT deleted. Error code: 500..
    
  2. There are either canceled or deleted tasks corresponding to affected subscription in task log.

  3. The error can be found on /var/log/poa.log on removing attempt:

    Sep 24 08:38:07 core.ccccloud.com : DBG [openapi:172.16.32.52:299030 1:24259:ebaa9b70 lib 623084260]: [ unprovisionResourceReference] {module_id="Common"; code="1"} Internal error: APSC: Unprovisioning: resource ba9870e3-0f3d-4279-be0d-7a310510dc43 of type 'nlsubscription' (http://nuvelink-service-management.com/nlsubscription/1.0) for APS application 'Nuvelink Service Management for Cloud-4.2-0': Catalog information not found. Contact Administrator.
    

Cause

Subscription provisioning was not completed thus some of APS resources it provided did not have the complete set of required APS properties.

When the subscription was being destroyed OA attempted to remove the APS resources subscription has but failed. Corresponding record in /var/log/poa.log:

Sep 24 08:38:07 core.ccccloud.com : DBG [openapi:172.16.32.52:299030 1:24259:ebaa9b70 lib 623084260]: [ unprovisionResourceReference] {module_id="Common"; code="1"} Internal error: APSC: Unprovisioning: resource ba9870e3-0f3d-4279-be0d-7a310510dc43 of type 'nlsubscription' (http://nuvelink-service-management.com/nlsubscription/1.0) for APS application 'Nuvelink Service Management for Cloud-4.2-0': Catalog information not found. Contact Administrator.

"Catalog information" is the set of APS properties specific for Nuvelink Application resources and each provisioned (in "aps:ready" state) resource has it. If subscription is not completely provisioned resource state is "aps:proto".

Apparently "Catalog information" is the mandatory set of properties and APS endpoint was refusing to remove the resource not having its "Catalog information".

Endpoint did not let OA remove "ba9870e3-0f3d-4279-be0d-7a310510dc43" resource, thus subsequent subscription resource was not removed as well.

Resolution

Contact Odin Technical Support to have th issue resolved.

Internal content

Link on internal Article