Symptoms

PACI-im service fails to restart with no apparent error message. Restart request from service PACI-im restart is processed for some time, but then fails silently. In messages the following lines could be seen:

PACI: Locked PACI service for start
PACI: IM start request
PACI: Starting Instance Manager
PACI: There is no logs last 240 seconds
PACI: FAILURE: Instance Manager cannot start
PACI: Unlocked PACI service for im-daemon

No errors in vps.log could be observed. Despite that, OACI IM processes could be seen in ps aux output, all Cloud Infrastructure UI tabs are accessible.

Cause

Incorrectly configured parameters of IM daemon, altered manually by customer. During startup IM performs a set of self-tests, one of which checks availability of API on port 4465 by accessing it via loopback address. If loopback connections are blocked, or IM configured not to listen on 127.0.0.1, this test will fails and services will not start.

Resolution

Find the following line in file /usr/local/share/PACI-im/IM-config.xml on OACI Instance manager node:

<listener host="x.x.x.x" keystore-pwd="secret" maxThreads="100" minThreads="5" name="insecure" port="4465" reuseAddress="false" secure="false" />

Set parameter host to 0.0.0.0:

<listener host="x.x.x.x" keystore-pwd="secret"...

Then perform restart of IM service.

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