Symptoms

Autoscale rules are not delivered to Virtuozzo hosts. Attempt to apply new autoscale rules results in its 'infinite' application in IM UI, but rules are never effectively applied on Virtualization side.

Autoscale set request is correctly processed on IM side and sent to VZ node. After some timeout an error could be seen in vps.log:

AutoscaleRuleDeliveryTask.error(-2, No response to SNMP SET operation)

According to network and firewall settings, communication ports of SNMP (1161, 161) are not blocked on both sides, however, according to tcpdump capture, packets are not sent back to IM. Additionally, checksum errors could be seen in dump:

# tcpdump -A -i any -vvv port 1162 or port 161

oaciim.provider.local.health-trap > 172.24.100.51.snmp: [bad udp cksum 5237!]  { SNMPv2c C=parallels { SetRequest<...>

Cause

Network issues or incorrect net device configuration.

Resolution

General recommendations are following:

  1. Disable unnecessary modules RmondMIB and systemview from /etc/snmp/smpd.local.conf:

    dlmod   RmondMIB        /usr/lib64/rmond/rmond.so
    view    systemview      included        .1.3.6.1.4.1
    
  2. Disable checksumming on backnet interface:

    # ethtool --offload  eth0  rx off  tx off
    # ethtool -K eth0 gso off
    
  3. Contact your local netwoek administrator to further investigate the issue.

Internal content