Symptoms

CCP v2 VPS Activity Log shows a failed Recreating VPS operation.

In fact, the VPS itself got reinstalled.

There is no failed task to recreate VPS in Provider's CP, it ended successfully.

/var/log/pa/vps.aps.log on the Management Node contains the message like:

2017-07-19 21:59:03,347 aps_9f93767b-9e1d-4859-956c-94521996e14f_271 DEBUG UserNotification$Sender [deferred] - Sending user notification UserNotification.Sender [notification=VE_RECREATE_NO_PASSWORD, template=NotificationTemplate [message=Failed to Recreate Server "__name__", details=__error__, linkText=null, link=null, status=ERROR], accountUuid=9dcfbd33-ec21-4e93-bac5-695035e28433, resourceUuid=acc68574-2f49-4e50-bdd8-d26bb58d58ae, name=server-1000101-1, osName=CentOS 7, error=[APS] {
        "error": "APS::Hosting::Exception",
        "message": "limit exceeded: 3535846029 > 3145728"

}

Cause

The behavior is recognized as a software issue with ID CCU-14043.

The issue appears on the final stage of VPS recreation routine, when APS resource limits are verified. In case of an APS error, the actual operation ends successfully in scope of OACI Instance Manager, but the end user gets an error.

Resolution

No action is required, the message is a false alarm in this particular case, and the VPS got recreated successfully.

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