Symptoms

After selecting Azure in online store on the next screen where prices should be displayed, the error appears:

Invalid request. Either price configuration ID, or service template ID, or customer account ID must be specified and a corresponding price list must be configured.
Error Category: api

The following could be seen in Azure logs:

2017-08-14 20:17:04,930 INFO  [com.odin.azure.api.PartnerCenter] (azure task-113) <PCSDK> Outgoing request: 'GET https://api.partnercenter.microsoft.com/v1/ratecards/azure?currency=USDion=US'
-headers:
...
        X-Locale: en-UK

2017-08-14 20:17:05,074 DEBUG [com.odin.azure.api.PartnerCenter] (azure task-113) <CREST> Request failed: [com.microsoft.store.partnercenter.exception.PartnerException] {"code":2000,"description":"Locale is not supported","data":["X-Locale"],"source":"RequestContextManager"}

Cause

Locale en_UK is not in the list of supported locales. APSA-18767 was submitted to Engineering team to address this issue.

Resolution

Currently there are no workaround for non-supported locales. The only way to overcome the issue is to use one of supported locales, like en_US or en_GB. Please contact your Technical Manager to acquire recent news about status of the issue.

Internal content