Symptoms

Office 365 Provisioning subscription task fails:

"code": 500,
"message": "Unauthorized",
...
"error": "ApplicationUnknownError",
"http_request": "POST /O365App/aps/subscriptions"

sitelog error:

[ 115] DEBUG flow: Creating subscription: bd938f12-058f-4927-bba3-ae36b1d2501c -> 1.
[ 115] ERROR flow: Caught unknown error:
Code: '0'
Message: 'Unauthorized'

Subscription in question is related to the Tier-1 CSP partner Reseller which has his own Application Instance.

Cause

Redundant MPN ID is configured for the Reseller on the BA side.

Resolution

Tier-1 resellers should not have a MPN ID assigned. Remove it in the: PCP > Billing > Resellers > [Affected Reseller] > Additional Information (tab) > MPN ID (field)

Internal content

Link on internal Article