Symptoms

  1. Send Notification task fails with the following output:

    WFLYEJB0447: Transaction 'TransactionImple < ac, BasicAction: 0:ffff0a070215:-1bd73015:593522f9:4ac status: ActionStatus.ABORTED >' was already rolled back
    

Message type is: #122 = "New Hotfixes Available" notification template.

  1. /var/log/maillog* on SMTP server contains a lot of stat=User unknown warnings:

    Jul 21 21:24:23.102 sendmail[20479]: v6LINp0B020334: to=<j.doe@domain.tld>, delay=00:00:22, xdelay=00:00:22, mailer=esmtp, pri=121095, relay=domain-tld.mail.protection.outlook.com. [203.0.113.2], dsn=5.4.1, stat=User unknown
    
  2. A lot of users are subscribed for notifications.

Cause

Each User unknown e-mail delivery error causes 20-30 seconds delay. This is the reason for task Send Notification failure: it is reaching default pau transaction 300 sec timeout.

The number of staff members to be processed by task is increased due to the fact the notification is trying to be sent to disabled users as well.

This issue is acknowledged as APS-42861.

Resolution

Make sure users subscribed are valid (and their e-mails are actual) or disable the notifications in PCP > System > Settings > Notification Subscriptions > [user_name] > Delete.

Internal content

Link on internal Article