Symptoms
An attempt to complete PROJECTCLIENT
offer provisioning fails with the following sitelog
output:
Code: 'OMS_7003'
Error: 'OfferExpired'
Message:'Offer id 'D3BCA131-4772-47BC-9C2E-E4040F82268C' is expired'
Parallels.Office365.CRestAPI.Requests.CRestErrorException: Offer id 'D3BCA131-4772-47BC-9C2E-E4040F82268C' is expired
Cause
Customer already has existent PROJECTCLIENT
subscription on the Microsoft cloud side, but its status is "Warning" for some reason. In that case request for subsequent PROJECTCLIENT
subscription provisioning fails with "OfferExpired" error.
Resolution
Contact Microsoft support using the sitelog
request and response pair as a reference to clarify the status of the behavior.
As a possible workaround, try to trigger licenses provisioning later by setting the OA subscription limits for them to 0 and back to the original quantity. The Microsoft side issue may be temporary.