Symptoms

Provider has some attributes that are applied to "Account" and are configured to be displayed in Online Store. One of these attributes has status "Required" and is disabled.

When a customer is creating a new account from Online Store he is asked for additional attributes and fills them. After successful account creation customer vendor is trying to get these attributes values but none of them are filled.

Cause

To save attributes to account Online Store calls API method UpdateObjAttrList_API where all filled parameters are passed. But eventually this method falls with the following exception:

The field "<ATTRIBUTE_NAME>" is mandatory. Please fill.

Where <ATTRIBUTE_NAME> is the name of disabled required attributed.

Also similar errors can be observed as Problem Reports which are generated at the moment of account creation.

The reason for such behaviour is software-related issue #PBA-72361.

Resolution

Mandatory attributes that are not used in Online Store during account registration can be marked as "Optional" to prevent method UpdateObjAttrList_API from updating such attributes.

Contact your Technical Account Manager or Pooled Technical Associate Team at pta@odin.com to clarify the status of #PBA-72361.

Internal content