Symptoms

Cancellation orders for a subscription hangs in "Provisioning" status. Subscription has been destroyed on Operations Automation side, however there is a failed Event "Deletion Completed".

The following entry can be observed in billing.scheduler.log:

[17-03-30 20:27:10.722 RemoteRes   RQ00114 TH00971 NTE] -> User-defined exception #60002 Parallels Operations Automation error #error_code #2006, extype_id #200, module_id #ResourceManagement, Subscription #XXXXXXX does not exist.

Cause

The issue is caused by #PBA-79892 "Resource usage is gathered for removed subscription during failed cancellation order resubmit"

Resolution

Please contact your Technical Account Manager or a member of Pooled Technical Associates Team to clarify status of the software issue.

As a workaround, please, follow the steps below:

  1. Go Home > Opeations > Orders and find the stuck or failed order;
  2. Switch to Provisioning Items tab;
  3. Remove the failed Provisioning Item;
  4. Resubmit the order for Provisioning;
  5. Update the Subscription Status and Service Status via API as it is described in the documentation.

Internal content