Symptoms
An APS application provisioning task fails. An example of the failure:
Internal error: Plesk::SaaS::SaaSManagerTasks_impl::taskExecuteWorkflow : [APSC] Provisioning: resource 81ef1333-492b-43da-befc-4281d306dcd5 of type 'tenant' (http://acronis.com/aps/cloud-backup-v1/tenant/9.0) for APS application 'Acronis Backup Cloud-2.1-1884': Modification of 'eba0ac51-8dd9-4ce9-b772-21c992f62a22' requested by linking to '81ef1333-492b-43da-befc-4281d306dcd5' is not allowed..
Accessing the application endpoint URL directly gives a page with PHP code:
# curl -vv -k https://192.0.2./backupservice/globals/eba0ac51-8dd9-4ce9-b772-21c992f62a22/tenant
In /var/log/pa/core.log
at the point of endpoint response:
Jun 1 16:46:56 THHS2PEMOSS01 : DBG [task:79672345:332786 1:10528:3f08 SAAS 1892894953]: [ HTTP] OUT Response headers: 'Connection:close' 'Content-Type:text/html; charset=UTF-8' 'Date:Thu, 01 Jun 2017 15:46:56 GMT' 'Server:Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips mod_fcgid/2.3.9 PHP/5.4.16' 'Transfer-Encoding:chunked' 'X-Powered-By:PHP/5.4.16'
Jun 1 16:46:56 THHS2PEMOSS01 : INF [task:79672345:332786 1:10528:3f08 SAAS 1892894953]: [ HTTP] OUT 192.168.251.67 [1455] "POST /backupservice/globals/eba0ac51-8dd9-4ce9-b772-21c992f62a22/tenant HTTP/1.1" [0] "200 OK" 78ms
the content type is Content-Type:text/html, while Content-Type:application/json is always expected.
Cause
The reason behind such a failure is an incorrect endpoint configuration. The response from application's tenant.php script is incorrect. One of the possible reasone: malformed opening php tag, e.g. <?php:
, when semicolon is not expected
Resolution
Validate the PHP scripts for syntax errors and resolve, if any. Make sure there are no Apache service errors in /var/log/httpd/error_log
during provisioning attempts.