Symptoms

After upgrade from OAP 7.0 to 7.1 version vendor users that had the ability to log in under customers in BA control Panel have the link "To Control Panel" missing.

What is causing this issue?

Cause

The reason is that starting from 7.1 version either privilege MANAGE_AFFILIATED_ACCOUNTS or CONFIG_SECURITY is required to see "To Control Panel" link. A software issue with ID #PBA-80502 was confirmed by Odin developers.

Resolution

In order to trace the current status of #PBA-80502, contact your Technical Account Manager or Pooled Technical Associate Team (pta@odin.com).

Please note that the workaround is only applicable for accounts of "Company" type. It can not be applied for personal accounts.

For personal accounts it will be required to assign one of the aforementioned privileges to account staff member billing role.

To workaround the issue for "Company" type accounts refer to details below:

  1. Assign "ACCOUNTS_VIEW_DET" privilege to staff member role.
  2. Create Account_GetWin.xml file in /usr/local/bm/customization folder with the following content:

    # cat Account_GetWin.xml 
    <window id="Account_GetWin">
    <actions>
    <constraint id="showLoginLink" ele="dataAccount Information:LoginLink">
      <show> vUserManagementAllowed "==" "0" </show>
    </constraint>
    </actions>
    </window>
    
  3. Perform restart of WWW service

            service pba restart www
    

Please be notified that during WWW restart PCP user interface will be unavailable for 1-2 minutes.

Internal content