Symptoms

Some MozyPro accounts have been created under the provider account, instead of a partner.

Such subscriptions are listed in Provider's CP at Applications > MozyPro > Instances > $select instance > Failed Subscriptions.

The OA core log shows that the request to create a mozyPro account took less than a second to complete:

Apr 17 14:25:50 core : INF [task:50005418:1647 1:2520:e240db90 SAAS 382920706]: [ HTTP] OUT  192.168.231.61  Begin request: "POST /mozy/mozyProAccount"
...
Apr 17 14:25:50 core : INF [task:50005418:1647 1:2520:e240db90 SAAS 382920706]: [ HTTP] OUT  192.168.231.61  [1663] "POST /mozy/mozyProAccount HTTP/1.1"  [2031] "200 OK"  897ms

The same request takes several seconds for a working subscription:

Apr 17 21:34:54 core : INF [task:50036658:30096 1:2520:e351eb90 SAAS 381729949]: [ HTTP] OUT  192.168.231.61  Begin request: "POST /mozy/mozyProAccount"
Apr 17 21:35:00 core : INF [task:50036658:30096 1:2520:e351eb90 SAAS 381729949]: [ HTTP] OUT  192.168.231.61  [1663] "POST /mozy/mozyProAccount HTTP/1.1"  [2583] "200 OK"  5476ms

The mozyPro endpoint log files contain these messages:

[2017-04-17 21:25:48] [INFO] mozyProAccount Provision Starting #
[2017-04-17 21:25:49] [INFO] Email address already exists in Mozy

The resulting mozyProAccount APS resource contains null values:

[root@core ~]# curl -kE /usr/local/pem/APS/certificates/poa.pem "https://localhost:6308/aps/2/resources/3305fce8-cb37-4ff0-b3aa-75df94c56b56/mozyProAccount"
[
        {
                "aps":
                {
                        "type": "http://www.mozy.com/mozyProAPS2/mozyProAccount/1.5",
                        "id": "7c65c917-810d-4db3-ba68-4332168f8489",
                        "status": "aps:ready",
                        "revision": 3,
                        "modified": "2017-04-17T19:25:51Z"
                },
                "user_group_id": null,
                "userName": null,
                "userFullName": null,
                                ...

Cause

In case an account with the same email address already exists on the mozyPro side, the creation of such account will not be possible in OA. CCP shows a message to choose a different email address during provisioning.

Resolution

Contact mozyPro support to delete the account and try to provision it again in OA.

Alternatively, use a different email address for the account creation.

Internal content