Symptoms
On attempt to generate Office 365 Reconciliation Report the following error appears in CP (branded URL case):
"Unknown error occurred"
and in browser console:
The corresponding service is not available at the moment. Try again in 2-3 minutes.
Same time, Reconciliation Report generator works fine locally via [backnet_ip_address]:8080
It could be seen in the sitelog
that the Reconciliation Report itself was successfully created on the Endpoint side:
DEBUG aps_endpoint: Office365AppController.GetReconciliationReport started: ("e44aed5d-314f-4d4e-aa6f-76a26d978f64", 1485907200000, 1488326400000, 1000001)
DEBUG Data : Db version: 201606071555
...
DEBUG aps_endpoint: Office365AppController.GetReconciliationReport finished
Cause
We are reaching the UI timeout due to huge orders\subscriptions quantity, owned by a Reseller or Provider.
This behavior has been submitted to Odin Development Team as requests:
#APS-36680: "O365 Reconciliation Report error: Failed to load resource (error 502)";
#APSA-16066: "Reconciliation report refactoring".
Resolution
Contact TAM or pta@odin.com in order to trace the status of the requests.
As a w\a please try to narrow Reconciliation Report date interval.