Symptoms
Change order or sales for subscription that includes CloudStore application resource fails with the following error:
Parallels Operations Automation error #error_code #0, extype_id #1, module_id #Common, Internal error: APSC: https://OA_MN_IP_ADDRESS:6308//aps/2/resources/0083d30f-8c26-4313-9f0c-00a6313c42a2.. .".
The following message could be seen in core.log
on the OA MN server:
ERR [rest:277067 1:21043:7f10a1b0a700 SAAS 1389374563]: [ APSC] REST Error: GET //aps/2/resources/0083d30f-8c26-4313-9f0c-00a6313c42a2 code=404: Specified resource `0083d30f-8c26-4313-9f0c-00a6313c42a2` is not found.
Resource 0083d30f-8c26-4313-9f0c-00a6313c42a2
is of OA subscription type and it could be seen that is is being requested as one APS application instance, but certificate is used from another instance. The following lines in core.log
unveil the discrepancy:
[ HTTP] OUT 127.0.0.1:8081 Begin request: "POST /cloudstore/rest/store"
[ HTTP] OUT Request headers: 'APS-Request-Phase:sync' 'Host:127.0.0.1:8081' ... 'APS-Instance-ID:42e576cf-aed5-40d2-b986-30ec3630da0e' ...
[ APSC] Created context without token. Application `77888870-123b-4302-ab15-f7ea6cd977c9` is the actor.
Cause
There are two application instances at the same endpoint. At the moment, CloudStore does not support several application instances and uses incorrect certificate to access the subscription resource.
Resolution
Configuration of CloudStore recommended for production environments include only one instance.
Request with ID PBA-79828 was passed to the Engineering team in order to allow support of more than one instance. Please contact your Technical Account Manager or Pooled Technical Associates team in order to clarify the status the issue.
Workaround for this situation requires direct database manipulations. Please contact Odin Technical support in order to acquire the workaround.