Symptoms

Office365 synchronization fails with the following error:

Failed to add 1 domain(s):
- domain.com (Unable to create domain in Operations Automation: Domain '__domain_name__' already exists.)

Cause

This domain had been added to Office365 previously, but removed for some reason. Some redundant Microsoft-related DNS records were not removed properly.

Check the /var/log/core.log on Management Node to obtain the exact error:

c.p.p.s.a.e.APSExceptionMapper Error occurred javax.ejb.EJBTransactionRolledbackException: 
Can not create DNS Record for 'msoid.domain.com.' 
There is an existing CNAME record (msoid.domain.com. clientconfig.microsoftonline-p.net., #191111) already.

Resolution

Remove the existing msoid.domain.com. CNAME DNS record and repeat the synchronization.

Internal content